数据库备份服务器上运行的版本8.00.2039.该版本与此服务器不兼容

SongKer 发布时间:2014-12-31 分类:Web 阅读:13300次 3 条评论

数据库备份还原时候,出现错误:“数据库备份服务器上运行的版本8.00.2039.该版本与此服务器不兼容”。

错误提示:The database was backed up on a server running version 8.00.2039. That version is incompatible with this server, which is running version 11.00.3000. Either restore the database on a server that supports the backup, or use a backup that is compatible with this server.

VERIFY DATABASE is terminating abnormally.

出现错误的原因:在SQL Server2000上备份的数据库无法在SQL Server2012上还原(可以分离附加),出现以上的错误。

解决办法:

第一种、使用SQL Server2008,如果还是坚持还原在SQL Service 2012上,用另一台安装有2008版本的还原之后再备份然后在2012在进行还原。

第二种、SQL Service 2000分离备份的数据库,复制在安装2012的服务器上进行还原。

已有3条留言
  • 王语双个人站
    发布于 2014-12-31 16:32:10  回复该评论
  • 图片真有创意!
    2014最后一天,过来留个爪印!祝博主:2014's 健康,金钱,美貌……大丰收。
    -____-"

发表评论:

◎欢迎您的参与讨论。